脚本开发,脚本学习,辅助软件
【腾讯云】新用户专属大礼包低至1折【阿里云】云产品通用代金券2000元【阿里云】云小站优惠返现【阿里云】企业级1折特惠【阿里云】3年低至3折
查看: 751|回复: 0

易语言检测虚拟机代码

[复制链接]

78

主题

80

帖子

607

积分

专属

Rank: 1

积分
607
发表于 2020-3-16 20:54:16 | 显示全部楼层 |阅读模式
本帖最后由 周周 于 2020-4-26 00:30 编辑
  1. .版本 2

  2. .子程序 __启动窗口_创建完毕



  3. .子程序 检测虚拟机, 逻辑型
  4. .局部变量 a, 整数型

  5. .如果 (try_ ())
  6.     a = VMWare检测 ()
  7.     try_out ()
  8. .否则

  9. .如果结束
  10. .如果真 (a ≠ 0)
  11.     返回 (真)
  12. .如果真结束
  13. .如果 (try_ ())
  14.     a = VPC检测 ()
  15.     try_out ()
  16. .否则

  17. .如果结束
  18. 返回 (a ≠ 0)

  19. .子程序 VMWare检测, 整数型, , 此函数不能独立在实体机中运行,否则进程异常
  20. .局部变量 a, 整数型

  21. 置入代码 ({ 184, 104, 88, 77, 86, 187, 0, 0, 0, 0, 185, 10, 0, 0, 0, 186, 88, 86, 0, 0, 237, 129, 251, 104, 88, 77, 86, 15, 148, 69, 252 })
  22. 返回 (a)

  23. .子程序 VPC检测, 整数型, , 此函数不能独立在实体机中运行,否则进程异常
  24. .局部变量 a, 整数型

  25. 置入代码 ({ 187, 0, 0, 0, 0, 184, 1, 0, 0, 0, 15, 63, 7, 11, 133, 219, 15, 148, 69, 252 })
  26. 返回 (a)

  27. .子程序 try_, 逻辑型

  28. 置入代码 ({ 232, 50, 0, 0, 0, 85, 139, 236, 131, 196, 236, 82, 139, 85, 12, 139, 69, 16, 255, 114, 8, 143, 128, 184, 0, 0, 0, 255, 114, 12, 143, 128, 196, 0, 0, 0, 255, 114, 16, 143, 128, 180, 0, 0, 0, 184, 0, 0, 0, 0, 90, 201, 194, 16, 0, 88, 201, 131, 236, 20, 139, 204, 137, 65, 4, 232, 0, 0, 0, 0, 88, 131, 192, 28, 137, 65, 8, 137, 97, 12, 100, 161, 0, 0, 0, 0, 137, 1, 100, 137, 13, 0, 0, 0, 0, 255, 97, 20, 100, 161, 0, 0, 0, 0, 139, 72, 20, 139, 0, 100, 163, 0, 0, 0, 0, 51, 192, 131, 196, 24, 255, 225 })
  29. 返回 (假)

  30. .子程序 try_out, 逻辑型

  31. 置入代码 ({ 201, 89, 100, 161, 0, 0, 0, 0, 57, 104, 16, 117, 28, 139, 80, 8, 129, 122, 228, 88, 131, 192, 28, 117, 16, 139, 96, 12, 139, 0, 100, 163, 0, 0, 0, 0, 131, 196, 24, 255, 225, 51, 192, 255, 225 })
  32. 返回 (假)

  33. .子程序 _检测按钮_被单击

  34. .如果 (检测虚拟机 () = 真)
  35.     信息框 (“程序禁止在虚拟机中运行”, 0, “提示”, )
  36. .否则
  37.     信息框 (“程序物理机中运行”, 0, “提示”, )

复制代码





上一篇:易语言多线程下许可证(临界点)的合理使用
下一篇:易语言快捷键
3Q4T网,编程学习交流基地。
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表