脚本开发,脚本学习,辅助软件
【腾讯云】新用户专属大礼包低至1折【阿里云】云产品通用代金券2000元【阿里云】云小站优惠返现【阿里云】企业级1折特惠【阿里云】3年低至3折
查看: 15|回复: 0

仿Win10的Loading模块:STLoadingForWin10-v1.1

[复制链接]

22

主题

22

帖子

149

积分

襁褓

Rank: 1

积分
149
发表于 2020-5-18 16:04:37 | 显示全部楼层 |阅读模式

仿照Windows10的Loading加载效果,代码很少。

直接编译可输出为模块,我电脑刚升级到Windows10,还编译不了程序,自己编译吧。

也是刚升级到Win10看效果不错就随手做了个,有毛边什么的可以考虑改造成GDI+或者使用图片代替画圆。


基本使用:

.版本 2

.程序集变量 _loading1, STLoadingForWin10

.子程序 _测试窗口_创建完毕

_loading1.SetGraphics (画板1)

.子程序 _时钟1_周期事件

_loading1.Update ()


有3个扩展方法可定义效果:

.Color 设置/获取颜色

.Speed 设置/获取速度

.PointWidth 设置/获取转动圆圈的直径

手动设置位置和绘制半径:

.SetPosition

下载链接:https://t00y.com/file/20110282-443934876





上一篇:高级文件目录选择框教程
下一篇:JimStone(谢栋)窗口自动缩放模块(源码+示例):STFormResizer
3Q4T网,编程学习交流基地。
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表